Solved

Date Parameter in a Generic Inquiry

  • 8 February 2024
  • 15 replies
  • 185 views

Userlevel 4
Badge

Community,

I created a new GI from the INPIDetail table.  In my GI, I am attempting to create a date parameter that is required.  I have it set up, but when I run the report, no matter the date entered, it will not return any results.  Looking for some pointers.

Parameters tab in the GI
Conditions tab in the GI
Report results.

The goal is to have the user be required to enter the date and return results from that date of the cycle count.  Most generally they will use this report the day they do their cycle count.

 

Thank you,

Trisha

 

icon

Best answer by frederickodendaal77 9 February 2024, 17:13

View original

15 replies

Userlevel 4
Badge

@jamesh .

Yes!  At this time I feel I’m where I need to be with it!

Thank you so much for help!

Trisha

Userlevel 6
Badge +6

@jamesh ,

Wow!  Now I do feel silly!  I have used that for other things but didn’t think to use it for that.  Goodness!  Glad it’s Friday!

 

Thank you!

No worries. It’s practically the weekend! Haha 😂 That’s why I try to include screenshots. None of us know everything!!! Hopefully that finally solves your issues. 
Take Care,

James

 

Userlevel 4
Badge

@jamesh ,

Wow!  Now I do feel silly!  I have used that for other things but didn’t think to use it for that.  Goodness!  Glad it’s Friday!

 

Thank you!

Userlevel 6
Badge +6

@jamesh ,

Might be a silly question but, how do I view your GI?  When I open it, it shows me the text view.  I not familiar with doing that step.

Thank you,

Trisha

Ahhh, you go to your Generic Inquiries screen, and where you exported it, you select Import instead.  It will pull it in for you. I kept the naming convention you had and GI number for your site map as well.  :) 

 

Userlevel 4
Badge

@jamesh ,

Might be a silly question but, how do I view your GI?  When I open it, it shows me the text view.  I not familiar with doing that step.

Thank you,

Trisha

Userlevel 6
Badge +6

@frederickodendaal77 ,

I didn’t realize that I could do that within the relations.  Now they want it as a date range (wasn’t mentioned before).  

Thank you for all your pointers!

@tveld - Here’s an updated GI with the date range ;)

 

Userlevel 4
Badge

@frederickodendaal77 ,

I didn’t realize that I could do that within the relations.  Now they want it as a date range (wasn’t mentioned before).  

Thank you for all your pointers!

Userlevel 3
Badge

@tveld If you need to use the CreatedDateTime field then you can do the following in the generic inquiry.

 

Remove all the conditions and then do the filter directly on the relations:

 

=LEFT([INPIDetail.CreatedDateTime],11)

 

Userlevel 6
Badge +6

Thanks for sharing the GI - I’ve made some adjustments.  Using a join and adding the CountDate field instead solved the issue. 

Attached the GI with the changes.

Userlevel 4
Badge

@frederickodendaal77 ,

Thank you!  Adding that header table did help get that date issue corrected.  My report is now working correctly!

 

Thank you to everyone who offered tips! @Laura02 , @jamesh 

Trisha

Userlevel 3
Badge

Hi @tveld Do you have to use created date time? Would the count/freeze date not work better in this scenario?
 

 

Userlevel 4
Badge

@jamesh  & @Laura02 ,

I added the value =Today() to my conditions.  It will pull in the whole report, not just the date specified.  I did read the post that @Laura02  mentioned as well.

I have tried different ways with the brackets, with no success.

I am currently just using the one table. So, I know there are no joines issues.

Conditions
Results Grid for my report

Any other ideas?  Also, not sure how to view attached GIs from here.  It opens up just as text. (new to this part of it).

Thank you,
Trisha

Badge +18

Hello @tveld ,

Dates may need to be converted, in order to compare them in a GI.  See this previous post answered by Laura Jaffe:

 

 

Laura

Userlevel 4
Badge

@jamesh,

Good morning,

That didn’t work.  I noticed on your screenshot that there is a small calendar icon by your date, but on mine it has a drop-down arrow.  I have attached my GI for reference.  This seems so simple, but it is not running right.

Thank you for your help!  

Trisha

Userlevel 6
Badge +6

Looks like you’re just missing brackets on your conditions.  Everything else looks perfect.  ;) 

Here’s one I have for Invoices by DocDate

If that doesn’t work, attach your GI here and I’ll take a look.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved