Solved

Import scenario to release a kit assembly works when run manually, but returns an error when the scenario is automated

  • 2 March 2022
  • 1 reply
  • 181 views

Userlevel 7
Badge +8

We have an import scenario based on a Generic Inquiry data provider to automate the release of Kit Assemblies. 

When the import scenario is run manually (from the Import by Scenario screen SM206036) it works perfectly and releases the Kit Assembly as expected.

However, when it is run using the “Prepare and Import” option from the Process Import Scenarios screen SM206035, the Release step returns an Error: Another process has updated the ‘INRegister’ record.  Your changes will be lost.

We have narrowed down the issue to the ‘Release’ action.  In the screenshot below the update to the Description field is successful.  We have tried with and without the ‘Save’ operation.  We also tried creating the Assembly and releasing it in a single import scenario but received the same error message there as well.

In our test example there is only a single record returned by the Generic Inquiry, so it must be somehow conflicting with itself.  

There seem to be two different versions of the release action on the Kit Summary dropdown menu (Release and Release@Action).  I’m not clear on the difference, but we have tried both with the same results.

Any ideas?  Thanks in advance!

icon

Best answer by lauraj46 3 March 2022, 15:35

View original

1 reply

Userlevel 7
Badge +8

For what it’s worth, this issue appears to be caused by a customization on the Kit Assembly screen.  

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved