Solved

Import Sales Orders with a Lookup

  • 26 October 2022
  • 2 replies
  • 243 views

Userlevel 5
Badge

I need to look for a sales order that MAY exist or MAY NOT exist in an import scenario and the order may be accessed multiple times across different imports. If the order doesn’t exist, I need the import to start a new order.

The import file has a customer reference number. This is a unique field and is my index to look for. If no match is found, I need a new order created. I thought the following commands were what I needed (ignore the highlighted line, it’s not active): 

 

 

I get two types of errors: If the commit box is checked on the line:

Order Nbr → Customer Order Nbr

When I run the import: I get the first row to process, everything says success, but all rows are skipped except the first row. In my 5 rows of test data the PurchaseOrderNumber field alternates between Test1 and Test2. So if I run it, I get a new order with Test1 and ONE item on it (should have 3). The two rows of Test2 get ignored as do the other Test1 Rows. If I run it AGAIN, a new Sales Line is added to the order with TEST1 on it, but it still skips Test2, which is the 2nd row of the import. So now Row 1 and Row 3 have processed successfully and everything else has been ignored.

If we do NOT check the commit box in the import scenario. This seems to access Existing records just fine, but it refuses to create a new order if no record is found. It outputs the error: The System Failed to Commit the Document Row.

I assume I’m missing something basic here, but everything I’m finding online mentions accessing existing records, not creating new ones. Anyone know how to get this import functioning as expected?

Thanks for your help in resolving this one!

icon

Best answer by lauraj46 27 October 2022, 16:27

View original

2 replies

Userlevel 5
Badge

Thank you! I didn’t even think about the cancel command. I was busy in the weeds trying to look at the data driven lines. Sometimes you need to come up out of the weeds to see the big picture. Thank you @lauraj46 !

Userlevel 7
Badge +8

Hi @Michael Hansen ,

I think you might just have an extra ‘Cancel’ on row 7 of your scenario.  If you’re not able to delete this row, try making it inactive.  This is a similar scenario that works for us:

Hope this helps!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved