Solved

Empty 200 response from API's while using OAuth2

  • 28 February 2022
  • 2 replies
  • 229 views

Hi, 
I am trying to make API calls with O Auth 2 Authentication but facing some issues, previously I used Authentication based on Cookie. So I followed the steps to create an O Auth 2 connection, create a client id, client secret with O Auth 2 Flow as ‘Resource Owner Password Credentials. The Bearer token is getting generated when I hit this access token URL “/identity/connect/token”. The issue is whenever I make an API call with the generated token I get a 200 response with No data (image attached).

 

 

First I got a response something like this :
<script>
    window.open("/Main","_top");
</script>
So I passed the Accept and Content-Type in the header and then started getting an empty response. 
(Note: A bulk import is happening from Acumatica using APIs, so is this because of API usage limits? I am not sure about this)
I'm new to this system and wonder if I'm missing something. 

Thanks

 

icon

Best answer by Nayan Mansinha 3 March 2022, 23:17

View original

2 replies

Userlevel 7
Badge

Hi @RanjithKumar  were you ever able to resolve your issue? Thank you!

Userlevel 4
Badge +2


(Note: A bulk import is happening from Acumatica using APIs, so is this because of API usage limits?

 

I don't think it is because of API usage as you are getting status code of 200 OK. Check in Request Profiler and see if anything shows up there that might give some clue.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved